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Chapter 1 Tutorial

QUICK TOUR

Getting Data

S-PLus is designed to work seamlessly with the software you already
use. You can import data from and export data to many sources,
including spreadsheets such as Excel and Lotus, databases such as
Access, analytical software such as SAS and SPSS, and the financial
databases Bloomberg, LIM, and FAME.

Once you have accessed your data, you can analyze and explore it. In
this quick tour, you will perform the following tasks:

* Open a data set.

» Create several two-dimensional plots.
» Identify and label points in those plots.
» Editaplot.

* View objects in the Object Explorer.
* Create a three-dimensional plot.

This quick tour briefly introduces you to many of the most commonly
used procedures in S-PLUS.

Let’s walk through a sample session using some data to help you
decide which new car you should buy.

1. From the main menu, select File » Open.

2. Navigate to the samples directory (a subdirectory of your
S-PLus installation directory) and select exfuel.sdd.

3. Click Open to load the file into a Data window.

The exfuel data set consists of five data columns plus a column of
row names:

* Weight: Automobile weight
* Disp.: Engine displacement (6 liter, 8 liter, etc.)

* Mileage: Mileage in miles per gallon

Fuel: 100/mileage

* Type: Category of vehicle (Large, Medium, Small,
Compact, Sporty, Van)
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To see a description of any column, hold the cursor over the column
name. To see the column type, hold the cursor over the column
number.

S-PLus provides 8 different column types: character, complex, dates,
double, factor, integer, logical, and single. Notice that Type is a factor
column representing categorical data.

Creating a 2D You can create a graph by selecting data columns and choosing a plot
Graph type.
1. Select all the columns of exfuel (from Weight to Type) by
dragging the mouse across the column headers.

2. Click the 2D Plots button on the Standard toolbar to open a
palette of available 2D plot types.
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2D Plots 3D Plots
Figure 1.1: The 2D Plots and 3D Plots buttons on the Standard toolbar.

3. Click the Scatter Matrix button on the palette.
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Figure 1.2: The Plots 2D palette.
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The scatterplot matrix displays each column of data against the other
selected columns. For example, to see how Mileage and Fuel are
related, read across from Mileage and above Fuel to see the plot.
The plot shows that Mi leage and Fuel are directly related. You can
also see a strong relationship between Mi leage and Weight: heavier
cars have lower mileage.
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Figure 1.3: The scatterplot matrix shows a number of strong relationships.

Linear
Regression

Now that you're familiar with your data,
relationship between Weight and Mi leage a bit more extensively.

let’'s examine the

1. Close the Graph Sheet containing the scatterplot matrix. You
do not need to save it.

2. Click the header of weight and then CTRL-click the header of
Mi leage in the Data window.
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3. Click the Linear Fit button (see Figure 1.2) on the Plots 2D
palette. This linear fit shows an obvious relationship between
an increase in Weight and a decrease in Mi leage (see Figure
14).
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Figure 1.4: Linear fit of Mi leage vs. Weight.

To examine how Vans or Compact cars fit into this example, you can
use MathSoft’s exclusive Trellis graphics to condition Weight and
Mi leage on a third variable, Type.

4. Minimize any open windows except the Data window and
Graph Sheet. You may need to minimize the Graph Sheet
and Data windows first and then restore them after
minimizing the other windows. Choose Window P Tile
Vertical (or press CTRL-SHIFT-V) to vertically tile the Graph
Sheet and Data windows side by side.

5. Select the Type column by clicking on its header. You may
have to use the slider at the bottom of the Data window to
locate the Type column. Then position the mouse somewhere
within the data so that the pointer arrow appears, not the
down arrow of the column header. Click and drag the data
column to the top of the Graph Sheet where a rectangle
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marked by dashed lines appears. A plus sign appears beneath
the mouse cursor when you have positioned the cursor
correctly, as in Figure 1.5. To create the Trellis graph, release
the mouse button to drop the data column into this rectangle.

3.57 =

Figure 1.5: Drag-and-drop to create Trellis graphs.

The resulting plot is shown in Figure 1.6. The data are divided into
subsamples and conditioned by Type. Now you can see additional
relationships:
* Sporty cars, normally assumed to be gas guzzlers,
actually have among the highest mileage, along with
Small cars.
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* Compact and Medium cars, often touted for higher
mileage, get gas mileage similar to Large cars.
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Figure 1.6: A Trellis view of the fuel data.

Identifyingand Now we can identify which cars have the best and worst mileage by
Labe|ing Data labeling the data points.
Points 1. Point the mouse cursor at any data point in the graph. A

DataTip appears, similar to a ToolTip, showing you the
vehicle’s model, weight, and mileage.

2. To label the point, click the Graph Tools toolbar button
on the Graph toolbar. To see the Graph toolbar, make sure
the graph sheet is in focus. On the Graph Tools palette, click

the Label Point button EI
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3.

Click on the data point you want to label. The data point is
labeled with the car description (the row name) and the values
of the plotted columns at that point. For example, if you click
on the uppermost data point in the Sporty cars panel, you'll
see the following label:

Honda Civic CRX Si 4.
Weight = 2170.00
Milleage = 33.00

SHIFT-click on additional points to label multiple points at
once.

Click on the Select Tool button ll from the Graph Tools
palette. Delete the labels by selecting them and pressing the
DELETE key.

Now we’ll change the contents of the DataTips and labels:

1. In the plot, right-click on any data point, and choose Data to
Plot from the shortcut menu.
2. Under DataTips and Point Labels, expand the column list.
Click on <ROWNAMES>, then CTRL-click on Disp. Press
OK. The model name and engine displacement are now
shown in the DataTips.
Editing the Now imagine that you want to include your graph in a report or
Graph presentation. You might want to modify its attributes further.

In S-PLus graphics are object-oriented, which means you have
complete control over every detail. You can easily modify graph
objects using shortcut menus, dialogs, or the toolbar.

1

Click on the X axis title, then SHIFT-click on the Y axis title on
the graph to select them. (Both axis titles are surrounded by
green knobs indicating that they are selected). Change the
font size to 20 using the Graph toolbar (see Figure 1.7).
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2. Click on any data point to select the plot. A single green
square will appear at the bottom center. Change the plot color
to Red using the dropdown Color menu by clicking on the
Line Color button on the Graph toolbar (see Figure 1.7).
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Figure 1.7: The Line Color button on the Graph toolbar changes text as well as line colors.

Databases and S-PLus does not operate on data files directly. Instead, S-PLUS stores

the Object
Explorer

ID@E[E| % Bl s o v iE

objects representing the data sets in an internal database. This means
that the original data file is not modified, and changes made to the
object stored in the database persist from session to session.
(However, you can choose to delete your changes at the end of each
session). S-PLus also keeps track of any graphs or other documents
that you have open during a session (Report windows, Script
windows). To see the contents of your current session, click on the
Object Explorer button on the standard toolbar.
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Object Explorer

Figure 1.8: The Object Explorer button on the Standard toolbar.

The Object Explorer uses folders to organize the documents and
data objects in your working database. Click on the Data folder and
notice that exfuel appears in the right pane of the Object Explorer.
Click on the Graphs folder to see the Graph Sheet windows open in
your current session. Now let’s create a folder to contain those objects
associated with our current analysis.

1. Right-click on the left pane of the Object Explorer and
choose Insert Folder from the shortcut menu.

2. Name the folder Car type analysis.
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Creating a 3D
Graph

10

3. Expand the Data folder by clicking on the + sign associated
with it.

4. Click on the exfuel object and drag it into the new folder you
created.

5. Expand the Graphs folder by clicking on the + sign
associated with it.

6. Click on the GS1 object and drag it into the new folder.
7. Expand the Car type analysis folder to view its contents.

You can customize your folder further by right-clicking on it and
choosing Folder, Objects, or Advanced from the shortcut menu.
Document objects (Graph Sheets, Reports, Scripts) that appear in
the Object Explorer are transient objects existing in your current
session, rather than permanent objects residing on disk. To save your
current session, including document objects and your customized
Object Explorer, use the menu option File » Workspace P Save.

S-PLus offers a variety of 3D plot types for powerful data
visualization. First let’s load some 3D data. The exgalaxy data set
contains measurements of the radial velocity of a spiral galaxy
measured at 323 points in the sky.

1. Choose File » Open and navigate to the samples directory.
(You can close all other windows. You do not need to save any
Graph Sheets.)

2. Type exgalaxy.sdd in the File name field and click Open.

3. Select the data columns east.west, north.south, and
velocity by CTRL-clicking on each column.

4. Click the 3D Plots button #1 on the Standard toolbar (see
Figure 1.1) to open a palette of available 3D plot types.
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5. Click the 3D Scatter button on the palette.
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Figure 1.9: The Plots 3D palette.

6. You can interactively rotate the 3D graph. Click outside the
surface plot but inside the 3D workbox area to select the
invisible 3D workbox (several green knobs should appear).
Drag horizontally on one of the green circles. When you
release the mouse, the graph is redrawn at the new
perspective. The green triangle can be dragged up and down
to rotate the graph vertically.

7. Click the plotted points of the graph to select the scatter plot.
A single green knob should appear. Then click the 4 Panel

Rotation button on the Plots 3D palette. Now you can
rotate the graph using the lower left panel. The panels will
rotate together so you can view your graph from different
angles.

11
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Figure 1.10: Four-panel rotation; note the circles and triangle used for controlling
the rotation in the lower left plot.
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EXTENDED TOUR: EXAMINING ENVIRONMENTAL DATA

Importing a File

Editing Variable
Names

Adding Column
Descriptions

In this extended example, we will import data from a SAS file and
edit the data. The data set contains measurements on ozone
concentration, solar radiation, daily maximum temperature, and wind
speed on 111 days in 1973 in the New York metropolitan area. After
editing, we visually explore the data with standard and Trellis plots.
We then fit a linear model to the data. We also edit the plots for
possible use in a presentation.

To import the data:

1. If you have any windows open from the preceding tutorial,
close them before continuing.

2. Choose File » Import Data » From File. S-PLus lists the
files in the current directory. We use File » Import Data
instead of File » Open because we are opening a SAS file
instead of an S-PLus file.

Under Files of type, choose SAS Files (*.sd2).
4. Navigate to the samples directory and select Exenvirn.sd2.
Click Open to load the file into a Data window.
Note that the imported SAS file has variable names all in uppercase
and at most eight characters long. In S-PrLus variable names are

highly flexible, so let’s modify the variable names before creating a
graph.

1. In the Data window, double-click the column name for
column 2 and change RADIATI10 to RADIATION.

2. Double-click on the column name for column 3 and change
TEMPERAT to TEMPERATURE.

You can store more detailed information about your data set in the
column descriptions. These column descriptions are automatically
used as axis titles when graphing the data.

1. Right-click anywhere on the column RADIATION.

2. Choose Properties from the shortcut menu.

13
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3. Enter Solar Radiation (langleys) inthe Description.

4. Click OK.

Saving the Data  We can now save our changes in an S-PLus data file. You store S-PLus
as an S-PLUS data files using the .sdd extension:
Data Set 1. Choose File » Save.

2. Accept the default samples directory and the default name,
Exenvirn.sdd.

3. Click OK.

Creating a 2D Now we are ready to visualize the data. We first create a local
Graph regression plot of the data:

1. In the Data window, select the data columns for RADIATION,
then CTRL-click OZONE. The first column will be the X data,
and the second will be the Y data.

2. Click the 2D Plots button to open a palette of available 2D
plot types.

3. Click the Loess button EZ on the palette. A locally weighted,
least squares regression is calculated and the plot is created.

4. Close the Plots 2D palette.

5. Click the maximize button in the upper right-hand corner of
the Graph Sheet.

6. Right-click on the smoothed line or any data point to access

the plot’s shortcut menu. Select Smooth/Sort to try different
levels of smoothing. Enter values between 0.1 and 0.9 in the
Span field and click Apply. Reset the Span to Auto, and
click OK.

Note

If you do not see a Smooth/Sort dialog option, you probably selected some other graph object.
Try again and make sure you click on a data point and not on an axis or axis label. S-PLUs
indicates with green knobs what object you have selected. Try clicking on different parts of the
graph (axis, labels, data, etc.) to see how different graph objects get highlighted with green knobs
when they have been selected.

14



Changing Graph
Features

Axes and Labels

Plot Properties

Titles

Extended Tour: Examining Environmental Data

S-PLus gives you unparalleled control over every detail of your
graph—right down to the thickness of tick marks. You can control all
individual line thicknesses, symbol sizes, fonts, colors, titles, tick
marks, and axis labels. Additionally, you can create multiple lines of
text for comments, titles, and tick labels. Superscript and subscript
options are conveniently located on a toolbar for quick access, so
editing any text or equation is easy.

1

Click on the y-axis to select it (a square green knob appears
on the center of the axis if you have properly selected it).

CTRL-click on the x-axis to select it.

Choose Format P Selected Objects. The Modify All
Selected Objects (if applicable) dialog appears.

In the Display/Scale page, specify Color: Lt Gray and
Frame: With ticks.

Click on the Grids/Ticks tab. Under Major Ticks, specify
Weight: 1 and Tick Position: In.

Click OK.

Change the y-axis title by clicking once to select the axis title
(green knobs surround the axis title when it is selected) and
once more to get an in-place edit box.

In the text edit box, type Ozone Concentration. Do not
press ENTER. Click outside the box to make the change.

Double-click a point in the plot to display the Line/Scatter
Plot dialog. A green knob appears at the bottom of the graph
indicating the plot object was selected.

On the Line page, specify the Line Color as Black and the
Weight as 2. On the Symbol page, specify Circle, Solid as
the Symbol Style and Red as the Symbol Color. Click OK.

Now we can insert a main title at the top of our graph. Choose
Insert » Titles » Main.

Type The Relationship Between Radiation and Ozone
into the text box that appears. Do not press ENTER. Click
outside the title to close the text box.

15
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Using Trellis
Graphics for
Multipanel

Conditioning

16

3. Select the main title and use the toolbar to specify a font size
of 20. Use the Line Color button to change the text color to
Blue. You can use the toolbar to change the font, font size,
and color of any text objects in your graph. Do not close the
Graph Sheet or Data window; we will use them again
shortly.

The Relationship Between Radiation and Ozone

Ozone Concentration

0 50 100 150 200 250 300 350
Solar Radiation (langleys)

Figure 1.11: After making all the changes to our graph, it now looks like this.

Suppose you have a data set with multiple variables and you want to
see how plots of two variables change with variations in one or more
conditioning variables. Exclusive to MathSoft, Trellis graphics are
designed to display your data in a series of panels using conditioning
options. Each panel contains a subset of the original data
corresponding to intervals of the conditioning variables.

Most graphs can be conditioned. The data columns used for each plot
and for the conditioning variable(s) must be of equal length. The axis
specifications and panel display attributes (for example, fill color) by
default are identical for each panel.
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Now we will apply multipanel conditioning to our previously created
loess plot.

1. Make sure that only the windows containing the Exenvirn
data and your Graph Sheet are open. Select Tile \Vertical in
the Window menu.

2. In the Data window, select TEMPERATURE, then CTRL-click
WIND.

3. Click and hold the mouse over the data in the columns until
the rectangular shadow appears, then drag-and-drop on the
rectangular drop target (the long bar) that appears at the top
of the graph.

The Relationship Between Radiation and O

R,

o

Figure 1.12: TEMPERATURE and WIND are dragged to the rectangular drop target
at the top of the graph.

The Trellis graph in Figure 1.13 shows how the dependence of 0ZONE
on RADIATION varies according to levels of WIND and TEMPERATURE.

17
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Ozone Concentration

The Relationship Between Radiation and Ozone
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Figure 1.13: Ozone concentration and solar radiation: This graph shows that radiation explains variation in
ozone levels beyond that explained by wind speed and temperature.

18

Select the plot by clicking the line or symbols in any one of the
panels. Open the Plots 2D palette and click on the Linear Fit button.
A linear regression line will replace the loess curve in each panel, as
shown in Figure 1.14. This graph suggests that high temperatures with
less wind result in the strongest dependence of ozone on radiation.
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The Relationship Between Radiation and Ozone
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Figure 1.14: A linear regression has replaced the loess curve in each panel.

Highlighting Data We can highlight data points in our graph and have the same points
Points highlighted in other graphs and the Data window.

1. Open the Graph Tools palette by clicking the button in
the Graph toolbar.

2. Click on the Select Data Points button &=,

3. Drag around a selection of points in the upper right panel of
the graph.

19
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Notice that the selected points are highlighted in both the
graph and the Data window. If we had other graphs based on
this highlighted data, the points would be highlighted in all
graphs.

4. Click on an empty part of the panel to remove the selection.

Extracting Graph You can “drill-down” into a Trellis graph panel using the Graph
Panels Tools.

1. Select the Extract Panel button B on the Graph Tools
palette.

2. Click on the upper right panel of the Trellis graph.
The panel is extracted and is displayed as a full-size graph.

3. Click the Show All Panels button 8 to restore the Trellis
graph.

Save the multipanel plot as mpanel.sgr, using File » Save As, and
close the Data window, the Graph Sheet, and any open palettes.

Note

The data set is not saved with the Graph Sheet. When the Graph Sheet is reopened, it will
redraw using the current data set named Exenvirn. To embed the data set within the Graph
Sheet before saving, choose Graph » Embed Data from the main menu.

Applying S-PLus provides a vast array of statistical techniques, with the most
Statistics widely used techniques accessible through dialogs launched from the
Models Data and Statistics menus.

All techniques available on the menus are available through the
S-PLus language. Commands may be issued interactively in the
Commands window or as a script in a Script window. In the course
of an analysis, the user may begin by fitting a model through a
convenient dialog, then proceed to analyze the model and perform
diagnostics through the flexible and powerful S language.

In this section, we will fit linear regression models to predict ozone
using temperature, radiation, and wind.

20
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Summaries First we will look at simple summaries of the data in the Exenvirn
data.

1. Choose File » Open and navigate to the samples directory.

2. Enter Exenvirn.sdd as the File name and click Open.

3. Choose Statistics » Data Summaries » Summary
Statistics.

4. The Summary Statistics dialog appears with Exenvirn in
the Data Set field. Click OK. Summaries for the columns
appear in the Report window.

5. Choose Statistics » Data Summaries » Correlations.

6. The Correlations and Covariances dialog appears with
Exenvirn in the Data Set field. Click OK. Correlations for
the columns appear in the Report window.

Linear Model Next we will use the Linear Regression dialog to fit a linear model

predicting ozone from the other variables.

Simple model from a dialog

1

In the Data window for Exenvirn, select OZONE, RADIATION,
TEMPERATURE, and WIND, in that order, by dragging across the
column headers.

Choose Statistics » Regression » Linear. The Linear
Regression dialog opens.

In the Data Set field, Exenvirn is listed.

In the Formula field, the formula expression OZONE ~
RADIATION + TEMPERATURE + WIND appears. The response,
or dependent, variable is OZONE and is listed first. The
predictors, or independent variables, are shown after the tilde
(=)

On the Plot page, check the box beside Residuals vs. Fit,
then click OK.

The regression results appear in the Report window. In addition, a
new Graph Sheet is created showing the diagnostic plots. The data
used in this plot are embedded within the Graph Sheet; subsequent

21
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changes in the Exenvirn data set will not affect these plots. See the
section Embedding and Extracting Data in Graph Sheets (page 27) for
more information.

The Formula Builder

The Formula Builder lets you describe complex regression models
by selecting variables and indicating how they are used in the model.
For example, you might want to add an interaction term to the model.
The Formula Builder lets you do this easily.

To use the Formula Builder

1

5.

Close the Graph Sheet. Again choose Statistics P
Regression » Linear. Select OZONE as the dependent
variable from the dropdown list. Then select RADIATION,
TEMPERATURE, and WIND (using CTRL-click) as the
independent variables. Notice that the formula reflects your
changes.

Now click the Create Formula button.

Select RADIATION and TEMPERATURE in the variable
list. Click on Add Interaction to include the interaction
between radiation and temperature as a predictor.

Click OK to exit the Formula Builder dialog. The formula
you generated is placed in the Formula field of the Linear
Regression dialog.

Click OK to generate the model.

More detailed results

1
2.

Choose Statistics » Regression P Linear.

Use the Dialog Rollback button at the bottom center of the
page (to the right of Apply) to select the previous dialog state.
The previous values for Data Set and Formula will be filled
in.

On the Results page, check the ANOVA Table check box.
This will provide an analysis of variance table for the linear
model.
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Click OK. The ANOVA table for the fit will appear in the
Report window.

When you are done looking at the results, close the Report
window and the Exenvirn Data window.
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DOING MORE WITH GRAPHICS

Varying 2D
Axis Types

D@ H S & ERon e oy NS

By default, 2D plots are drawn on linear x and y axes. Sometimes it is
useful to create plots using a logarithmic or probability scale on one
or both axes. You can most easily create such plots by selecting your
2D axis type from the toolbar before selecting your plot type.

1. Select File » Open, and navigate to the samples directory.
Change the Files of type dropdown to Data Sets (*.sdd,
*.axd).

2. Select expuro.sdd.
Click Open to load the file into a Data window.

4. Select the columns conc, vel, and state by dragging the
mouse across the column headers.

This data set is from a biochemical experiment testing the drug
Puromycin. The column conc gives the enzyme concentration of the
substrate and vel is the initial velocity of the reaction. The state
variable indicates whether or not the cell had been treated with
Puromycin.

5. Choose Log X from the Default 2D Axis Type dropdown in
the standard toolbar.

D %lf. . ;xl l;;

IﬁlLinear j o

1 -] B

Default 2D Axis Type

Figure 1.15: Choosing the Default 2D Axis Type.
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6. Click the Color plot button L in the Plots2D palette. The
treated and untreated cell observations appear in different
colors.

7. Make sure your graph is not selected, then change the
Default 2D Axis Type back to Linear. The Default 2D
AXxis Type control specifies the default axis type; if you don’t
change it back to Linear, subsequent plots are created on a



Creating
Graphics With
Multiple Axes

8.

Doing More with Graphics

log scale as well. If your graph is selected when you change
the default axis type, the axis type of your selected graph is
also changed.

Close the Graph Sheet and Data window.

You can create plots showing different data series, with varying scales,
against a single x or y variable. This is often useful in plotting, for
example, revenue and profit against time. You can see at a glance
whether revenue and profit are rising and falling together, or if some
more complicated relationship holds.

As a simple example, we’ll plot housing starts and manufacturing
shipments on a time scale.

1

Select File » Open, and navigate to the samples directory.
Change the Files of type dropdown to Data Sets (*.sdd,
*.axd).

Select execon.sdd.
Click Open to load the file into a Data window.

Select the columns years, hstart, and ship by dragging the
mouse across the column headers.

Choose Graph » 2D Plot. The Insert Graph dialog
appears.

Under Axes Type, choose Multiple Y. Under Plot Type,
choose Scatter. Accept the default Graph Sheet, GS1, then
click OK. A plot appears with hstart plotted along the left y
axis, ship along the right y axis, both plotted against years
along the x axis.
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7. Choose Insert » Legend. Drag the legend to the upper left
of the plot, to create the plot shown in Figure 1.16.
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Figure 1.16: A plot with multiple y axes.
Another way to show data series with varying scales is to put the
series in separate panels:

8. Select the rectangular plot area defined by the axes. Change
the Default 2D Axes on the Standard toolbar to Vary Y
Panel. The graph is redrawn, placing each plot in a separate
panel. The y axis is scaled separately in each panel.

9. Close the Graph Sheet. Save it as execon.sgr. Close the
Data window as well.

10. Change the Default 2D Axes back to Linear.
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Embedding
and Extracting
Data in Graph
Sheets

Creating a
Graph Using
the Object
Explorer

Doing More with Graphics

You can store the data used to create any graph within the Graph
Sheet. This lets you provide a fully editable graph to friends or
colleagues, without having to provide a separate data file. You can
also extract the data used to create the graph from any Graph Sheet,
and then analyze and manipulate the data.

To embed the execon data in the Graph Sheet:
1. Open the Graph Sheet execon.sgr.
2. Choose Graph » Embed Data.

The data used to create the graph (but no other data) are embedded
in the Graph Sheet.

To extract the data used to create a graph:

1. Select the Graph Sheet from which you want to extract the
data.

2. Choose Graph P Extract Data. The Extract Data dialog
appears.

3. Specify a name (such as execon2) for the extracted data set,
and click OK.

Before proceeding, close all open Graph Sheets and Data windows.

The Object Explorer is particularly useful when creating graphs from
a data set with many columns. First load the data set exstate.

1. Choose File » Open and navigate to the samples directory.
2. Type exstate.sdd in the File name field and click Open.

The exstate data set has many columns showing information about
states in the United States. To get a visual summary of the data set, use
the Object Explorer.

1. Bring the Object Explorer into focus. Expand the Data
folder in the left pane. Notice that the data set exstate is now
there.

2. Click on the button representing exstate in the left pane of
the Object Explorer. All of the columns are listed in the right
pane.
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3. Click on the column icon for Income, then CTRL-click on
Illiteracy, then Area. These columns are now also selected in
the Data window. Close the Data window since we will use
the Object Explorer for graphing.

4. Open the 2D Plots palette, and click on the Loess button.
Two loess plots are created in a Graph Sheet, both scaled to
the same set of axes. (We assume in the next procedure this
Graph Sheet is named GS1.)

Editing a Plot in  Using the Object Explorer and properties dialogs, you can edit any
the Object open Graph Sheet. As an example, we will change the format of the
Explorer X axis labels.

1. Bring the Object Explorer into focus, and expand the
Graphs folder.

2. Expand GS1 (or whichever corresponds to the plot you just
created) in the left pane of the Object Explorer.

3. Expand Graph2D, then click on Axis2dX1, both in the left
pane.

4. Double-click on Axis2DLabelX in the right pane to bring up
the X Axis Labels properties dialog.

5. On the Labell tab, change the LabellType to Decimal and
set the Precision to 1.

Viewing Plots in  The relationships between the variables can be seen much more
Separate Panels clearly if they are scaled to different Y axes. One way to do this is to
view the plots in separate panels, keeping the X axis scaling the same.

1. Click on a blank spot anywhere inside of the axes region to
select the graph.

2. Open the Graph Tools palette.
3. Click on the button in the lower left corner, labeled

Separate Panels with Varying Y Axes. Your plots appear
in two panels, stacked one over the other.
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Removing
Outliers

Creating a 3D

Graph

Doing More with Graphics

Notice that there is one data point far from the others. If you point
your cursor at the data point you will see that it represents Alaska.
Let’s remove this outlier from the plots.

1

Click on the Select Data Points button B2 on the Graph
Tools palette.

Drag a rectangle around the point representing Alaska to
select it.

Choose Format » Exclude Selected Points from the menu.
The loess smoothing is recalculated and the points
representing Alaska are removed from the plots.

Click the Select Tool button ® to return to the selection
Ccursor.

Close the Graph Sheet and Object Explorer.

Now we will use the data set ex3dsurf to create a 3D plot. Close any
open Graph Sheets or Data windows.

1

Select File » Open, and navigate to the samples directory.
Change the Files of type dropdown to Data Sets (*.sdd,
*.axd).

Select ex3dsurf.sdd.
Click Open to load the file into a Data window.

Select the columns V1, V2, and V3 by dragging the mouse
across the column headers.

Click the 3D Plots button to open a palette of available 3D
plot types.

Click the Spline Surface button & on the palette. The graph
shown in Figure 1.17 appears.
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Figure 1.17: 3D spline plot.

Adding Color

Now we will add color draping to the spline plot.
Draping

1. Click on the maximize button in the upper right-hand corner
of the Graph Sheet.

Click on the mesh of the surface plot to select it. On the Plots

3D palette, click the 32 Color Surface button & The graph
redraws with the new format.
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Figure 1.18: Color draping can be done with up to 64 colors.
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CREATING POWERPOINT SLIDES AUTOMATICALLY

32

You can automatically create a PowerPoint presentation from your
graphs. We will use the graphs we have created during this
demonstration to create a PowerPoint presentation (assuming you
have PowerPoint installed).

1. Click the PowerPoint Presentation button (e on the
Standard toolbar. You will see the Welcome screen of the
PowerPoint Presentation Wizard. Click Next.

2. You can now add saved graphs to the PowerPoint
presentation. Click the Add Graph button to find your
graphs and add them to the list for your presentation or, from
the standard File » Open dialog, select one or more graphs
to add to the presentation. Click Next to move to the next
page of the wizard.

3. Click Finish. PowerPoint is started and the graphs you chose
are inserted as slides in a new PowerPoint presentation. They
are inserted in the order you specified in the presentation list
in the wizard.



Managing Your Data

MANAGING YOUR DATA

Saving a Data Set
to the Working
Data

There are two ways to save data in S-PLus: in a file or in a database.

As with other standard Windows products, you can create, open, and
save your data sets through the File menu. In addition, S-PLus
automatically saves your data sets in an internal S-PLus database.
This database, called the working data, is the database in which all
S-PLus data objects are stored by default. Data objects can be
removed from the database at any time using the Object Explorer.
Simply select the data object and press DELETE.

At the end of every S-PLuUs session, a dialog prompt appears, listing
all the data objects that you have created or modified during the
current session. Use this dialog to tell S-PLus which changes to keep
and which to ignore for each data set.

1. To end the current S-PLus session and display the Save
Database Changes dialog, click on the x in the upper right-
hand corner of the S-PLus window.

Save Databaze Changes |

The following databaze objects have been created or modified
during thiz gezsion. Current werzions of relected objectz will be —

zaved in the databaze.

Cancel

Desslectall | Select Al

¥ Display Dialog On Exit

Figure 1.19: The Save Database Changes dialog.

By default, all objects created or modified during the current session
are selected in the dialog.
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To save a new data set or a changed version of an existing data
set in the internal database, leave its name highlighted.

To discard a new data set or any changes made to an existing
data set, CTRL-click on its name in the dialog.

Click OK.



Using the Commands Window

USING THE COMMANDS WINDOW

For some analyses, it is more convenient to work with an interactive
data analysis language than to maneuver through a series of dialogs.
We will use the Commands window to fit another linear model and
perform some diagnostics. If it is not already open, open the

Commands window using the Commands Window button 3 on
the Standard toolbar. Close all other windows.

fit.lm <- 1m{0Z0NE-RADTATION+TEMPERATUREHIIND ﬂ
H data = Exenwvirn)

fit.lm J
Call:
lm(formula = OZONE ~ RADIATION + TEMPERATURE + WIND, data = Exenwvirn)
Coefficients:

{Intercept) RADIATION TEMFERATURE WIND

-0.2973296 0.002Z05541 0.05004432 -0.07602195
Degrees of freedom: 111 total; 107 residual
Residual standard error: 0.5101592

-

4| I 3 i

Figure 1.20: The Commands window.

The Commands window gives you interactive access to the S-PLUS
language. Everything you type in S-PLUS is an expression. Expressions
are evaluated when you press the ENTER key. If you press ENTER
after an expression that is syntactically incomplete, it is not evaluated;
however, it does not result in an error, either. Instead, S-PLUS
prompts you to continue the expression with the + continuation
prompt.

You can type several expressions on the same line by separating them
with semicolons (;). S-PLuUS evaluates each in succession when you
press ENTER. A semicolon is not required at the end of each line; only
between multiple expressions on a single line. You can include
comments in S-PLUS expressions following a # symbol. Anything
after the # on a line is interpreted as a comment, and is not evaluated.

The result of any expression is an object that may be saved by
assigning it a name using the assignment operator <-. (The
assignment operator is typed by typing a “Less than” character
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Listing Objects

Fitting a Linear
Model
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followed immediately by a “hyphen”; do not put any spaces between
the two characters.) All data used in S-PLuUS is represented as some
type of S-PLuUS data object.

Most S-PLuUs expressions are function calls, since S-PLus is a functional
language. To call a function, type the name of the function followed
by a set of parentheses containing any arguments to the function.

S-PLUS commands are case-sensitive. S-PLUS ignores most spaces, so
you can include or omit spaces in typing your expressions as you
prefer. Do not place extra spaces within the name of an object,
however, or between the digits of a single number, or between the <
and - in the assignment operator.

The Commands window uses a > prompt. In this document, text
starting with > is to be typed at this prompt. Do not type the >.
1. If you have not already done so, use File » Open to load
Exenvirn.sdd from the samples directory.

2. To replicate the regression results and store them in an object
named fit. Im, type the following (remember that the S-PLUsS
language is case-sensitive):

> fit.Im <- Im(OZONE~RADIATION+TEMPERATURE+WIND,
+ data = Exenvirn)

3. To see a brief summary for the model, type:

> Fit.Im

When fitting the model using dialogs, we added one interaction term
to examine the interaction between temperature and radiation in
determining ozone level. We now fit a model containing interactions
and explore whether the interactions are significant.

1. Tofit a linear model with all two-way interactions, type:

> fit.int <- Im(OZONE ~ (RADIATION + TEMPERATURE +
+ WIND) ~ 2, data = Exenvirn)

2. For a brief summary of the fit:



Using the Commands Window

> fit.int

3. For a detailed summary:

> summary(Fit.int)
4. For an F-test comparing this model to the model fit above:

> anova(fit.Im, Ffit.int)

Getting Help for To get help for a command, such as anova, when working in the
Commands Commands window, type

> help(anova)
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USING THE SCRIPT WINDOW

Getting Help for
Commands

38

The Script window makes it easy to edit and run several lines of
commands. To open a Script window, choose File » New to bring
up the New dialog, then choose Script File. To run the script, click

the Run button ¥, or press F10. To run only selected commands,

first highlight them and then click the Run button ¥ or press F10.
There is no prompt in the Script window. If no output appears in the
lower pane, choose Options » Text Output Routing and click
Script Output in both columns.

Q Script] - output [_ (O] x|
—————r::::——————————————————————————————————————————————————————

fit.lm <- lm(DZDNE~RADIATIDN+TEHPERATURE+H&ND, |
data = Exenwvirn)
summary (£it.lm)

> fit.lm <- lm(0Z0NE ~ RADIATION + TEMPERATURE + WIND, data = Exenwvirn)
> summary(£it.lm)

Call: Ilm(formula = OZONE ~ RADIATION + TEMPERATURE + WIND, data =
Exenvirn)
Resziduals:
Min 10 HMedian 30 Max
-1.122 -0.3764 -0.02535 0.3361 1.495

Coefficients:
Value 5td. Error t wvalue Pri>=|t]

[Intercept) -0.2973 0.5552 -0.5355 0.5934

RADIATION 0.0022 0.0008 3.9453  0.0001 —
TEMPERATURE 0.0500 0.0061 §.1957 0.0000
WIND -0.0760 0.0158 -4.8253 0.0000

Residual standard error: 0.5102 on 107 degrees of freedom
Multiple R-Scquared: 0.6807 hd|

Figure 1.21: The Script window showing an S-PLuUS language script and
regression output.

To get help for an S-PLus language command when working in the
Script window, highlight the command and press F1.
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Q Scriptl - program M=k I
b /
fit.ln <- lm(0Z0NE~RFADIATION+TEMPERATUREHIIND , -
data = Exenwvirn)
% 5-PLUS Language Reference [_ (O] x|
File Edit Bookmark Options Help
Help Iopicsl Bach | Frint | e | s |

summary Summarize an Object - Generic Function

-
DESCRIPTICN

Provides a synopsis of an object.

Thiz function is genenic (zee Method 2); method functions can be
written to handle specific classes of data. Classes which already
have methods for this function mnclude:

aov, aovlist, data. frame, factor, garm glm, lm loess, mwlm
mz, nls, ordered, terms, tree,

USAGE
summary (ohject, ...)

REQUIRED ARGUMENTS
ochiect any object, mcluding a fitted model object of various lands, a data
frame, or a factor.

|

Figure 1.22: Getting help for the summary function when working in the Script

window.
Running an To run an S-PLus language script:
$-PLUS Language 1. Choose File » Open and navigate to the samples directory.

Script
2. Enter exhypbll.ssc as the File name and click Open. A

Script window opens with the script in the top pane.
3. Click the Run button "F. The script output appears in the
bottom pane.

4. Go to the bottom of the top pane of the Script window and,
using the mouse, highlight the function name nls. Press F1 to
see a complete description of this function.

5. Close the Script window.
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SUMMARY: BASIC PROCEDURES

Using Main
Menus

Using Shortcut
(Right-Click)
Menus

40

In this tutorial, you have used virtually all of the basic procedures you
need to use S-PLus effectively. This section summarizes those basic
procedures.

S-PLus menus change, depending on the type of window you are
working on. For example, if the active window (the highlighted
window) contains a Data window, the menus display options useful
for operating on Data windows. Graph Sheet and programming
options are absent or dimmed.

Menu options with a » symbol at the end of the line display a
submenu when selected. Menu commands with an ellipsis (...) after
the command display a dialog when selected. To cancel a menu, click
outside the menu or press Esc.

[Comys
File Edt Yiew Data [EIGeY Graph Options window Help

IJ 0w |l | = | Data Summaries > | gan | OYE i | Iﬁm o
_— LCompare Samples 3

| Power and Sample Size

Design

Linear...
Al Robust MH....
Mixed Effects Robust LTS...
Generalized Least Squares Stepwige...
Survival
Tree
Compare Models. ..

Generalized Additive..
Local [Loess]...

LCluster Analysiz

. Generalized Linear...
Multivariate

Log-linear [Foisson]...

Buality Contral Charts Logistic...
Fezample Frobit....
Smoothing

Time Series

Figure 1.23: Choosing Nonlinear Regression from the Statistics menu.

When you click the right mouse button, a shortcut menu for the
selected object is displayed. Shortcut menus contain options specific
to the selected object. The shortcut menu appears to the right or left
of the mouse pointer.



Dialogs

The Apply Button

The Dialog
Rollback Buttons

Summary: Basic Procedures

To close a shortcut menu without choosing an option, click outside the
menu or press Esc.

Sometimes choosing a menu option or clicking the mouse displays a
dialog. You can use dialogs to specify information about a particular
action. There are two types of dialogs: action dialogs and properties
dialogs. Action dialogs carry out commands, such as copying a
column. Properties dialogs display and allow you to modify the
properties (characteristics) of the selected object.

Dialogs can contain multiple, tabbed pages of options. To see the
options on a different page of the dialog, click the page name or press
CTRL-TAB to move from page to page. When you choose OK or
Apply (or press ENTER), any changes made on any of the tabbed
pages are applied to the selected object.

Most of the dialogs are modeless. They can be moved around on the
screen, and they remain open until you choose to close them. This
means you can make changes in a dialog and see the effect without
closing the dialog. This is useful when you are experimenting with
changes to an object and want to see the effect of each change.

Modeless dialogs have an Apply button. The Apply button acts
much like an OK button except that it does not close the dialog. You
can specify changes in the dialog and then choose the Apply button
or press CTRL-ENTER to see your changes, keeping the dialog open so
that you can make more changes without having to reselect the
dialog. If no changes have been made to the dialog since it was last
opened or “applied,” the Apply button is dimmed. When you are
ready to close the dialog, you can choose Cancel or just double-click
the close box on the dialog.

The Dialog Rollback buttons let you restore a dialog to a prior state.
You can scroll back through each of the prior states until you find the
set of values you want. Then you can modify any of these values and
choose Apply or OK to accept the entire current state of the dialog
(that is, to change the corresponding object or issue the corresponding
command, depending upon the type of dialog). One use of Dialog
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Rollback is to restore an object to a previous state. This is different
from Undo in that rollback can be applied selectively to an individual

object.

Typing and The following tasks can be performed in dialogs using the special

Editing in Dialogs keys listed below.

Table 1.1: Shortcut keys when using dialogs.

Move to a specific option and select it

Display a dropdown list

Select an item from a list

Close a list without selecting any items

Action Special Keys
Move to the next option in the dialog TAB

Move to the previous option in the dialog SHIFT-TAB
Move between pages in a multipage dialog  CTRL-TAB

ALT-underlined letter in the option name: Press
again to move to additional options with the same
underlined letter.

ALT-down arrow

Up or down arrow to move, ALT-down arrow to
close the list

ALT-down arrow

Using Toolbars Toolbars contain buttons that are shortcuts to menu selections. You
and Palettes can use toolbar buttons to perform file operations, such as opening a
file or saving a file. You can also use toolbar buttons to make
immediate changes to selected objects, such as font or color changes.

S-PLus displays two toolbars: the Standard toolbar and a special
toolbar that changes depending on the type of sheet being edited. You
cannot turn off the display of Standard and special toolbars.
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DataTips

Using Toolbar
Buttons

Displaying
Palette Buttons

Summary: Basic Procedures

When you pause the mouse over a toolbar or palette button, helpful
ToolTips appear:

Graph Option:  “Window Help

Restore Data Objects

You can control whether ToolTips are enabled in the General
Settings dialog. Select Options » General Settings to see the
dialog. If Enable ToolTips is checked, tip windows will appear.

DataTips are like ToolTips, except that they display information
about the current data set in a Data window or Graph Sheet. They
are displayed, for example, when you hover over a point in a scatter
plot, or over the column number in a Data window.

P

Ford Probe
Milzage = 30.00
o “Weight = 2695.00

Iu] jul]

You control whether DataTips are enabled using Options »
General Settings.

When you position the mouse pointer over a toolbar button, a
description appears at the bottom of the screen in the status bar. Like
menu options, some toolbar buttons may not be available at all times.
Inactive toolbar buttons are dimmed (for example, the Undo button
is dimmed if there is nothing to undo).

Several buttons display a palette of options when selected. For
example, the 2D Plots button will display a palette of 2D plot types.
Tool palettes remain in view until you click the toolbar button again
or click the palette’s close box. Leaving a tool palette in view is
convenient when you are experimenting with different options.
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Selecting,
Opening, or
Importing
Data

Selecting Data

44

The first step in virtually any S-PLus task is to select, open, or import
a data set to work on. Each of these terms has a specific meaning in
S-PLus. Selecting a data set means choosing one data set from among
the data objects stored in S-PLUS’s internal databases. Opening a data
set means choosing an S-PLus data file from your hard disk or
network file system and opening it in S-PLus. Importing a data set
means choosing a data file in any of S-PLus’s supported file formats
(for example, Excel) and opening it in S-PLus. In general, the result of
each of these tasks is to open a Data window displaying the selected,
opened, or imported data.

You can select data either from the Select Data dialog or from the
Object Explorer. If you want to look at the data in a Data window,
and want to have the data visible as you proceed with your tasks, the
Select Data dialog is probably simplest and fastest. If you want to
work with many separate data objects with which you are already
somewhat familiar, the Object Explorer can be much more efficient.

To select data from the Select Data dialog:

1. Choose Data P Select Data. The Select Data dialog
appears.

2. Inthe Source group of radio buttons, select Existing Data.

3. Inthe Existing Data group, type a data object name or select
a data object from the dropdown menu in the Name combo
box.

4. Click OK. The selected data appears in a Data window.

To select data from the Object Explorer:

1. Click the Object Explorer button " on the standard toolbar
to open the Object Explorer.

2. Double-click the Data icon in the left pane, or equivalently,
click the “+” sign to the left of the Data icon. The Data folder
expands to show the currently filtered data objects in the left
pane.

3. Click a data object to select it. The right pane displays a listing
of the data object’s variables. Double-click the item to show
the data object in a Data window.



Opening Data

Importing Data

Selecting
Variables to
Plot

Summary: Basic Procedures

To open a data set:

1. Click the Open button & on the Standard toolbar, or
equivalently, choose File » Open. The Open dialog
appears.

2. Navigate to the directory containing the desired file.
Select the desired file.

4. Click Open.
You can import data from a file, from the major financial databases
LIM, FAME, and Bloomberg, or via an ODBC connection. ODBC
connections allow you to extract data sets from enterprise databases.
In all cases, there are numerous options you can specify; the
procedures given here are for the simple case where you want to read

an entire data file. See the section Importing and Exporting Data
(page 52) in the User’s Guide for additional details.

To import a data set from a file:

1. Choose File » Import Data » From File. The Import
Data dialog appears.

2. Navigate to the directory containing the desired file.
3. Select the desired file.
4. Click Open.

To import data from the financial databases, see the section Importing
Data From Financial Databases (page 61) in the User’s Guide. To
import a data set from an ODBC connection, see the online help.

Once you've chosen a data set, you create plots by selecting variables
from the data set and then choosing a plot type from a plot palette or
the Insert Graph dialog. You can select variables in either a Data
window or the Object Explorer.

To select variables in a Data window:

» Drag your mouse across the column header to select one or
more contiguous variables.
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Creating Plots
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Click in one column header, then SHIFT-click in another to
select a range of variables. All the variables between the
variable in which you first click and the variable in which you
SHIFT-click are selected.

Click in one column header, then CTRL-click in one or more
other columns to select noncontiguous variables.

To select variables in the Object Explorer:

Click one variable name, then SHIFT-click another to select a
range of variables. All the variables between the variable you
first click and the variable you SHIFT-click are selected.

Click one variable name, then CTRL-click one or more other
variable names to select noncontiguous variables.

Once you have selected one or more variables to plot, you can create
plots easily by clicking on one of the plot buttons in the Plots2D or
Plots3D palette. Table 1.2 shows the plot types most commonly
associated with a given number of selected variables. Plots appear in a

Graph Sheet window.
Table 1.2: Common plots associated with a given number of variables.
Number of
Selected Plots
Variables
1 Boxplot, histogram, density, histogram density, QQ
normal with line, dot, bar, pie.
2 Scatter, line, line/scatter, isolated points, high density,

horizontal high density, step, curve fit (linear, robust
linear, polynomial, nonlinear, exponential, natural log,
power, log 10, spline, supersmooth, loess), QQ, Y series.




Editing
Graphics

The Graph Sheet

Summary: Basic Procedures

Table 1.2: Common plots associated with a given number of variables.

Number of
Selected Plots
Variables
3 Bubble, color, text-as-symbol, scatterplot matrix, grouped

bar, stacked bar, grouped bar with error, stacked bar with
error, contour (line or filled), 3D scatter, 3D line, 3D line
scatter, 3D dropline.

4ormore XY pairs, scatterplot matrix, grouped bar, stacked bar,
high-low-close, error bar.

You edit your graphics by selecting specific objects within the Graph
Sheet and either directly manipulating the object, or using menus,
dialogs, and toolbars to edit the selected object. As an example of
direct manipulation, consider the 3D rotation described in the section
Creating PowerPoint Slides Automatically (page 32). As an example
of using menus, dialogs, and toolbars, consider the plot editing
described in the section Changing Graph Features (page 15).

In S-PLus we distinguish between the Graph Sheet, the graph area,
and the plot area. The Graph Sheet is best described as the sheet of
paper on which we draw our plots. When you print, you print one or
more pages of a Graph Sheet. A Graph Sheet can contain more
than one graph. The graph area refers to the rectangle surrounding
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the data points, axes, legends, graph title, etc. The plot area is the
rectangular area within the graph where the data are plotted. See
Figure 1.24 for an illustration.

Graph Sheet (can contain more than one graph)

graph area (axes, labels, etc.)

plot area (data)

Figure 1.24: A Graph Sheet with graph area (gray) and plot area (center).
Within the plot area, you can select either the plot area itself or the
plot within.

» To select the plot area, click a blank area within the plot area.

» To select the plot, click any plotted element (line, symbol,
filled region, etc.).

Axes and axis titles are editable and selectable separately on 2D
graphs. Axis labels are formatted per axis.

» To select an axis, click the axis itself or within the tick marks.
* To select an axis title, click it.

» To select an axis’ labels, click any label.
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To select the plot, click any plotted data (points, lines, filled regions)
within the plot area. Figure 1.25 shows the difference in the two

methods of selection.
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Figure 1.25: Selecting the plot vs. selecting plot area.
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WHAT'S NEW IN S-Prus 2000

S-PLuUs 2000 is a major upgrade of S-PLus, including the following
new or enhanced features:

1. Statistics

New easier-to-use statistics dialogs, including a new
Variables group for simple model specification. See the
Statistics chapter in the User’s Guide.

Enhanced discriminant analysis (homoscedastic (linear),
heteroscedastic (quadratic), proportional covariances,
equal correlation, common principal components,
canonical discriminant function), with a new dialog. See
the chapter Discriminant Analysis in the Guide to
Statistics, Volume 2.

Enhanced LME/NLME. New, state-of-the-art code,
contributed by Doug Bates of the University of
Wisconsin—Madison and José Pinhiero of Lucent
Technologies, is included. There are dialogs for linear
and nonlinear mixed-effects models, and linear and
nonlinear models fit with generalized least squares. See
the chapter Linear and Nonlinear Mixed-Effects Models
in the Guide to Statistics, Volume 1.

Enhanced Survival Analysis. This includes a new
survival library from Terry Therneau at the Mayo
Clinic, along with some enhancements to the
accelerated life testing (censorReg) functionality, plus
revised and enhanced dialogs. See the chapters on
survival analysis in the Guide to Statistics, Volume 2.

Enhanced Quality Control charts now include a number
of moving average charts, and there are new dialogs for
creating these charts. See the chapter Quality Control
Charts in the Guide to Statistics, Volume 2.
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2. Data

* Import data from the leading financial databases:
Bloomberg, FAME, and LIM. See the section
Importing Data From Financial Databases (page 61)
in the User’s Guide.

» Data manipulation capabilities and dialogs have been
greatly enhanced:

i. Block operations (copy, move, transpose, clear, remove)

ii. Operations on rows and columns (copy, move, transpose,
clear, remove, pack, append, stack, unstack).
Noncontiguous and conditional sets of rows and columns
can be specified.

iii. Data Fill, Create Categories, and Subset Builder
dialogs

» DataTips now show column type and column
description. Just point the mouse cursor at the column
number to see the column type, or at the column name
to see the column description.

* New data.sheet data object has been added. Similar
to a data frame, the data sheet object type provides
increased flexibility. Most importantly, you can have
data columns of different lengths stored in a data sheet.

» Save, load, and create data objects via the File menu.

4. New Object Explorer (see the chapter Organizing Your
Work in the User’s Guide.)

* View an outline of your data objects and your
documents in the left pane. Expand and contract the
outline as you do in the Windows Explorer.

* View the contents of any object in the right pane, along
with explanatory information.

» Add your own folders to the Object Explorer. Add
objects to it by filtering or by drag-and-drop.

 Select data columns from the right pane of the Object
Explorer and graph them with the plot palettes.

» View and manipulate time series objects.
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5. Graphics (see the chapter Creating Plots in the User’s Guide).

» DataTips and labeling have been added to scatter plots.
Point your mouse cursor at a data point in a scatter plot.
A DataTip appears showing the values of your data for
that point. Customize the contents of the DataTip for
each plot on the Data to Plot page of the plot’s dialog.
Use the Label Data Points tool to create a comment
with the contents of the tip.

* New plot types have been added to the 2D plot palette.
The first five plot types are completely new to S-PLuUS.
The remaining plots have been added to the 2D plot
palette for easy accessibility.

i. Combined vertical/horizontal error bar charts. Draw
graphs showing errors for both the x and y directions.

ii. High-low-open-close plots. Plot financial data showing
not only the high and low values for the day, but also a
marker showing the open and close values. Alternatively,
draw a candlestick plot to show the open-close region.

iii. Multiple x-y pairs. Plot two or more pairs of x-y data
series on the same plot by selecting the data columns and
clicking on a plot button.

iv. Nonlinear curve fitting plots. Specify your own model,
and the fitted line will be calculated and drawn.

v. Smith Charts. A new plot type most often used by
engineers.

vi. \ector Plots

vii.Polar Plots

viii.Power Fit

ix. Ln Fit

X. Log 10 Fit

xi. Friedman’s Supersmooth
xii.Horizontal High Density

xiii.Horizontal Step Plots
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xiv.Horizontal Error Bar Charts
xv. Grouped Horizontal Bar Charts.

* New Default 2D Axis toolbar option and new Insert
Graph dialog let you specify 2D axis types before you
create your plot, as well as showing you a clear picture
of the type of plot you're creating. For example, select
three columns of data, then choose Multiple Y axes
and a scatter plot. Two plots are created, and the second
plot is scaled to an automatically created right y-axis.
Or, choose Log Y to have the scaling on your y-axis
automatically set to Log scaling.

» Embed data into your Graph Sheet so that it can be
saved as a single file.

» Extract data from a Graph Sheet to link the plots to
data. For example, if you've created a graph from the
command line, you can later extract the data used
within in it and have it put into a data set. Examine the
data, edit it, draw other graphs with it, and interactively
select data points on the graph.

16. Saving and Loading the Workspace (see the chapter
Organizing Your Work in the User’s Guide.)

» Workspace files can be saved and loaded. Each
workspace file contains a complete description of the
workspace, including sizes and positions of open
documents and user-specified paths.

17. Enhanced History Log

» By default, the history log is now condensed, showing
quick summaries of your actions. You can choose to see
full commands, if you prefer.

18. Automation (see the chapter Automation in the Programmer’s
Guide.)

» Greatly enhanced automation server capabilities,
especially for using C++ and Java to write automation
clients for S-PLus.

» Enhanced automation client capabilities.
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19.

20.

21.

22.

23.

24,

» New automation help capabilities. Generate HTML files
containing entire object hierarchy in S-PLus, including
all internal objects and methods and user-defined
functions.

GUI customization and deployment

o Drill down capability in Object Explorer for
Functioninfo objects and for properties makes dialog
creation much easier.

Interacting with other products

* New S-PLus component for Mathcad

Improved speed

o Start-up speed up to 50% faster (depending on machine)
Y2K compliance.

» S-PLuUs 2000 for Windows/NT has had complete Y2K
test coverage

User-contributed libraries from Brian Ripley and William

\enables, and from Frank Harrell.
Documentation
» The documentation set has been revised and expanded.

» Tips of the Day to improve your efficiency have been
added.

* New sample files have been added to the samples
directory:

i. Many sample graphs and data sets

ii. New automation examples
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